在升级wordpress时遇到的“这通常是因为存在不一致的文件权限”的报错处理方法

因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限

遇到这种问题,不用慌

其实这个问题很简单,就是因为权限导致。解决办法就是给目录赋予权限

把该文件的读写权限改为“可读可写”(755)状态

懒人的做法就是直接在网站根目录下,给wp-admin/,wp-includes/, wp-content/ 目录文件修改写入权限。

linux上具体做法就是

chmod 755 /home/wwwroot/你的自己WP网站目录/wp-admin/
chmod 755 /home/wwwroot/你的自己WP网站目录/wp-includes/
chmod 755 /home/wwwroot/你的自己WP网站目录/wp-content/

如果还是不行,那你就要检查一下你的另外一个地方的权限

检查nginx权限
ps aux|grep nginx

检查php权限
ps aux|grep php

 

给我们这个需要升级的目录赋予权限
chown -R www.www /home/wwwroot/你的自己WP网站目录/wp-admin/

也给插件目录赋予一下
chown -R www.www /home/wwwroot/你的自己WP网站目录/wp-content/plugins/

版权声明:
作者:ivpsr.com
链接:https://ivpsr.com/249.html
来源:VPS部落
文章版权归作者所有,未经允许请勿转载。

THE END
分享
二维码
< <上一篇
下一篇>>